blob: 9f043f9544feb0af363558781775e0ca121e2a4b [file] [log] [blame]
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-dns/c-ares/c-ares-1.7.5.ebuild,v 1.1 2011/08/21 11:23:15 angelos Exp $
EAPI=4
inherit eutils
DESCRIPTION="C library that resolves names asynchronously"
HOMEPAGE="http://c-ares.haxx.se/"
SRC_URI="http://${PN}.haxx.se/download/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="*"
IUSE="static-libs"
DOCS=( AUTHORS CHANGES README README.cares RELEASE-NOTES TODO )
src_prepare() {
# chromium:649040
epatch "${FILESDIR}"/c-ares-1.7.5-mkquery-heap-overflow.patch
}
src_configure() {
econf \
--enable-nonblocking \
--enable-symbol-hiding \
$(use_enable static-libs static)
}
src_install() {
default
find "${ED}" -name "*.la" -exec rm {} + || die
}