Refactoring: simplifying passwords filling code 1.

Context: code for filling passwords in DOM is very convoluted. For username
first flow, we need to fill only usernames, which is hard to do in the current
setup. Let's refactor!

This CL contains:
1.FillFormOnPasswordReceived is removed. It basically delegates filling to
FillUserNameAndPassword, which is used now.
2.Checking origin of parent frames moved to a helper method.
3.2 arguments removed from FillUserNameAndPassword, they may be computed from
other args anyway.

The further CL will contain more simplification to FillUserNameAndPassword.

Bug: 875768, 959776

Change-Id: Id1658401a8ec683a1a8db1117e816fe87f7dbaae
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1738554
Reviewed-by: Maxim Kolosovskiy <kolos@chromium.org>
Commit-Queue: Vadym Doroshenko <dvadym@chromium.org>
Cr-Commit-Position: refs/heads/master@{#684338}
2 files changed